<!DOCTYPE html>
<html lang="en-US">
<head>
	<meta charset="UTF-8">
	<meta name="viewport" content="width=device-width, initial-scale=1">
	<link rel="profile" href="http://gmpg.org/xfn/11">
	<!-- Optimized by SG Optimizer plugin version - 5.6.5 -->
	<!-- This site is optimized with the Yoast SEO plugin v14.9 - https://yoast.com/wordpress/plugins/seo/ -->
	<title>Obituaries - Martinsville Media</title>
	<meta name="robots" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
	<link rel="canonical" href="https://martinsvillemedia.com/local/obituaries/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Obituaries - Martinsville Media" />
	<meta property="og:description" content="Obituaries are updated daily by 9:30 a.m. and are provided by local funeral homes. Send notices to info@martinsvillemedia.com [&hellip;]" />
	<meta property="og:url" content="https://martinsvillemedia.com/local/obituaries/" />
	<meta property="og:site_name" content="Martinsville Media" />
	<meta property="article:published_time" content="2020-09-05T13:15:50+00:00" />
	<meta property="article:modified_time" content="2020-09-05T13:15:51+00:00" />
	<meta property="og:image" content="https://martinsvillemedia.com/wp-content/uploads/2020/03/mourning-3066701_1280.jpg" />
	<meta property="og:image:width" content="1280" />
	<meta property="og:image:height" content="853" />
	<meta name="twitter:card" content="summary_large_image" />
	<meta name="twitter:image" content="https://martinsvillemedia.com/wp-content/uploads/2020/03/mourning-3066701_1280.jpg" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://martinsvillemedia.com/#website","url":"https://martinsvillemedia.com/","name":"Martinsville Media","description":"WHEE-WMVA-WYAT","potentialAction":[{"@type":"SearchAction","target":"https://martinsvillemedia.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://martinsvillemedia.com/local/obituaries/#primaryimage","inLanguage":"en-US","url":"https://martinsvillemedia.com/wp-content/uploads/2020/03/mourning-3066701_1280.jpg","width":1280,"height":853,"caption":"obituary"},{"@type":"WebPage","@id":"https://martinsvillemedia.com/local/obituaries/#webpage","url":"https://martinsvillemedia.com/local/obituaries/","name":"Obituaries - Martinsville Media","isPartOf":{"@id":"https://martinsvillemedia.com/#website"},"primaryImageOfPage":{"@id":"https://martinsvillemedia.com/local/obituaries/#primaryimage"},"datePublished":"2020-09-05T13:15:50+00:00","dateModified":"2020-09-05T13:15:51+00:00","author":{"@id":"https://martinsvillemedia.com/#/schema/person/52ce522b2720c980f33793a901e85c6d"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://martinsvillemedia.com/local/obituaries/"]}]},{"@type":"Person","@id":"https://martinsvillemedia.com/#/schema/person/52ce522b2720c980f33793a901e85c6d","name":"Staff","image":{"@type":"ImageObject","@id":"https://martinsvillemedia.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/98fc372d6e1e8996a18e84727f5681ef?s=96&d=mm&r=g","caption":"Staff"}}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Martinsville Media &raquo; Feed" href="https://martinsvillemedia.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Martinsville Media &raquo; Comments Feed" href="https://martinsvillemedia.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Martinsville Media &raquo; Obituaries Comments Feed" href="https://martinsvillemedia.com/local/obituaries/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/martinsvillemedia.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.5.1"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://martinsvillemedia.com/wp-includes/css/dist/block-library/style.min.css?ver=5.5.1' type='text/css' media='all' />
<link rel='stylesheet' id='wordpress-popular-posts-css-css'  href='https://martinsvillemedia.com/wp-content/plugins/wordpress-popular-posts/assets/css/wpp.css?ver=5.2.4' type='text/css' media='all' />
<link rel='stylesheet' id='hive-style-css'  href='https://martinsvillemedia.com/wp-content/themes/hive-lite/style.css?ver=1.3.3' type='text/css' media='all' />
<link rel='stylesheet' id='hive-fonts-css'  href='https://fonts.googleapis.com/css?family=Noto%20Serif%3A400%2C700%2C400italic%7CPlayfair%20Display%3A400%2C700%2C900%2C400italic%2C700italic%2C900italic&#038;subset=latin%2Clatin-ext' type='text/css' media='all' />
<link rel='stylesheet' id='easy-notification-bar-css'  href='https://martinsvillemedia.com/wp-content/plugins/easy-notification-bar/assets/css/easy-notification-bar.css?ver=5.5.1' type='text/css' media='all' />
<script type='application/json' id='wpp-json'>
{"sampling_active":0,"sampling_rate":100,"ajax_url":"https:\/\/martinsvillemedia.com\/wp-json\/wordpress-popular-posts\/v1\/popular-posts","ID":13002,"token":"3069ee3c46","lang":0,"debug":0}
</script>
<script type='text/javascript' src='https://martinsvillemedia.com/wp-content/plugins/wordpress-popular-posts/assets/js/wpp.min.js?ver=5.2.4' id='wpp-js-js'></script>
<script type='text/javascript' src='https://martinsvillemedia.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp' id='jquery-core-js'></script>
<link rel="https://api.w.org/" href="https://martinsvillemedia.com/wp-json/" /><link rel="alternate" type="application/json" href="https://martinsvillemedia.com/wp-json/wp/v2/posts/13002" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://martinsvillemedia.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://martinsvillemedia.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.5.1" />
<link rel='shortlink' href='https://martinsvillemedia.com/?p=13002' />
		<!-- Custom Logo: hide header text -->
		<style id="custom-logo-css" type="text/css">
			.site-title, .site-description-text {
				position: absolute;
				clip: rect(1px, 1px, 1px, 1px);
			}
		</style>
		<link rel="alternate" type="application/json+oembed" href="https://martinsvillemedia.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fmartinsvillemedia.com%2Flocal%2Fobituaries%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://martinsvillemedia.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fmartinsvillemedia.com%2Flocal%2Fobituaries%2F&#038;format=xml" />
<link rel="icon" href="https://martinsvillemedia.com/wp-content/uploads/2020/03/MM_logo-50x50.jpg" sizes="32x32" />
<link rel="icon" href="https://martinsvillemedia.com/wp-content/uploads/2020/03/MM_logo.jpg" sizes="192x192" />
<link rel="apple-touch-icon" href="https://martinsvillemedia.com/wp-content/uploads/2020/03/MM_logo.jpg" />
<meta name="msapplication-TileImage" content="https://martinsvillemedia.com/wp-content/uploads/2020/03/MM_logo.jpg" />
			<style id="customify_output_style">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</style>
			<script data-ad-client="ca-pub-8317202989437408" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script></head>

<body class="post-template-default single single-post postid-13002 single-format-standard wp-custom-logo fpt-template-hive-lite group-blog has_sidebar">

				<div class="easy-notification-bar">

					<div class="easy-notification-bar-container enb-textcenter enb-system-font">

						
						
					</div>

				</div><!-- .easy-notification-bar -->

			<div id="page" class="hfeed site">

	<a class="skip-link screen-reader-text" href="#content">Skip to content</a>

	<header id="masthead" class="site-header" role="banner">

		<div class="container">
			<div class="site-branding">
				<a href="https://martinsvillemedia.com/" class="custom-logo-link" rel="home"><img width="1360" height="600" src="https://martinsvillemedia.com/wp-content/uploads/2020/04/cropped-martinsville-media.png" class="custom-logo" alt="Martinsville Media" srcset="https://martinsvillemedia.com/wp-content/uploads/2020/04/cropped-martinsville-media.png 1360w, https://martinsvillemedia.com/wp-content/uploads/2020/04/cropped-martinsville-media-300x132.png 300w, https://martinsvillemedia.com/wp-content/uploads/2020/04/cropped-martinsville-media-1024x452.png 1024w, https://martinsvillemedia.com/wp-content/uploads/2020/04/cropped-martinsville-media-768x339.png 768w, https://martinsvillemedia.com/wp-content/uploads/2020/04/cropped-martinsville-media-450x199.png 450w" sizes="(max-width: 1360px) 100vw, 1360px" /></a>
				<h1 class="site-title site-title--large">
					<a href="https://martinsvillemedia.com/" rel="home">
						Martinsville Media					</a>
				</h1>

				<div class="site-description">
					<span class="site-description-text">WHEE-WMVA-WYAT</span>
				</div>
			</div>

			<nav id="site-navigation" class="main-navigation" role="navigation">
				<h5 class="screen-reader-text">Main navigation</h5>
									<button class="navigation__trigger">
						<span class="c-burger c-burger--fade">
							<b class="c-burger__slice c-burger__slice--top"></b>
							<b class="c-burger__slice c-burger__slice--middle"></b>
							<b class="c-burger__slice c-burger__slice--bottom"></b>
						</span>
						<span class="screen-reader-text">Menu</span>
					</button>
				<ul id="menu-home" class="nav  nav--main"><li id="menu-item-11193" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-11193"><a href="https://martinsvillemedia.com">Home</a></li>
<li id="menu-item-11025" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-11025"><a href="https://martinsvillemedia.com/whee/">WHEE</a></li>
<li id="menu-item-11024" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-11024"><a href="https://martinsvillemedia.com/wmva/">WMVA</a></li>
<li id="menu-item-11023" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-11023"><a href="https://martinsvillemedia.com/wyat/">WYAT</a></li>
<li id="menu-item-11248" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-11248"><a href="https://martinsvillemedia.com/contact-us/">Contact Us</a></li>
</ul>			</nav><!-- #site-navigation -->
		</div>

	</header><!-- #masthead -->

	<div id="content" class="site-content">

		<div class="container">

	<div id="primary" class="content-area">
		<main id="main" class="site-main" role="main">

			
<article id="post-13002" class="post-13002 post type-post status-publish format-standard has-post-thumbnail hentry category-local">
	
	<header class="entry-header">

		<div class="entry-meta">
			<span class="posted-by"> <span class="author vcard">
					<a class="url fn n" href="https://martinsvillemedia.com/author/wdbillwyatt/">Staff
					</a>
				</span></span>
<span class="posted-on"><a href="https://martinsvillemedia.com/local/obituaries/" rel="bookmark"><time class="entry-date published" datetime="2020-09-05T09:15:50-04:00">September 5, 2020</time></a></span>				<span class="cat-links">
					<a href="https://martinsvillemedia.com/category/local/" rel="category tag">Local</a>				</span>
					</div>
		<h1 class="entry-title">Obituaries
</h1>
	</header><!-- .entry-header -->

			<div class="entry-featured  entry-thumbnail">
			<img width="1024" height="682" src="https://martinsvillemedia.com/wp-content/uploads/2020/03/mourning-3066701_1280.jpg" class="attachment-hive-single-image size-hive-single-image wp-post-image" alt="obituary" loading="lazy" srcset="https://martinsvillemedia.com/wp-content/uploads/2020/03/mourning-3066701_1280.jpg 1280w, https://martinsvillemedia.com/wp-content/uploads/2020/03/mourning-3066701_1280-300x200.jpg 300w, https://martinsvillemedia.com/wp-content/uploads/2020/03/mourning-3066701_1280-1024x682.jpg 1024w, https://martinsvillemedia.com/wp-content/uploads/2020/03/mourning-3066701_1280-768x512.jpg 768w, https://martinsvillemedia.com/wp-content/uploads/2020/03/mourning-3066701_1280-84x55.jpg 84w, https://martinsvillemedia.com/wp-content/uploads/2020/03/mourning-3066701_1280-49x32.jpg 49w" sizes="(max-width: 1024px) 100vw, 1024px" />					</div>
	
		<div class="entry-content" data-first_letter="O">
		
<p><em>Obituaries are updated daily by 9:30 a.m. and are provided by local funeral homes. Send notices to info@martinsvillemedia.com</em></p>



<figure class="wp-block-audio aligncenter"><audio controls src="https://bfpodcasts.s3.amazonaws.com/OBITS.mp3"></audio><figcaption>Obituaries</figcaption></figure>



<p>James Lyle Blankenship, 82, of Martinsville, died Sunday. Wright Funeral Service is in charge.</p>



<p>C. Harlowe Bowling, 81, of Ridgeway, died Tuesday. The funeral will be held Saturday, at 11 a.m. at Moody Funeral Home. Interment will be held in the Woolwine Cemetery.</p>



<p>Geraldine Draper, 90, of Martinsville, died Tuesday. Norris Funeral Service is in charge.</p>



<p>Mary Elizabeth Greer, 73, of Spencer, died Monday. Wright Funeral Service is in charge.</p>



<p>Norman Jones, 70, of Martinsville, died Monday. Wright Funeral Service is in charge.</p>



<p>Charles Ray Marshall, 52, of Martinsville, died Tuesday. Wright Funeral Service is in charge.</p>



<p>Rebecca Shively Minter, 77, died Sunday. Bassett Funeral Service is in charge.</p>



<p>Charles Donald Purcell, 87, of Ridgeway, died Monday. Services will be held at a later date. Wright Funeral Service is in charge.</p>



<p>Dorothy &#8220;Becky&#8221; Rebecca Taylor, 84, of Martinsville, died Wednesday. A private memorial service will be held Saturday, at 11 a.m. at Norris Funeral Service.</p>



<p>Janice Plaster Turner, 67, of Stuart, died Tuesday at Forsythe Hospital. Norris Funeral Service in Stuart is in charge.</p>



<p>Caroline Lester Weidhaas, 65, of Stuart, died Sunday. A funeral service will be held Sunday, at 2 p.m. at Moody&#8217;s Funeral Home in Stuart. Burial will follow at Bouldin Memorial Presbyterian Church, in Stuart. A public viewing will be Saturday, from 12 until 5 p.m.</p>



<p>Wayne J. Williams, 79, of Patrick Springs, died Sunday, at Sovah Health. Norris Funeral Service in Stuart is in charge.</p>
	</div><!-- .entry-content -->

	
	<footer class="entry-footer">
		Posted in <a href="https://martinsvillemedia.com/category/local/" rel="category tag">Local</a>. Bookmark the <a href="https://martinsvillemedia.com/local/obituaries/" rel="bookmark">permalink</a>.	</footer><!-- .entry-footer -->

</article><!-- #post-## -->

		</main><!-- #main -->
	</div><!-- #primary -->


<div id="secondary" class="sidebar  sidebar--main" role="complementary">
	<aside id="search-4" class="widget widget_search"><form role="search" method="get" class="search-form" action="https://martinsvillemedia.com/">
				<label>
					<span class="screen-reader-text">Search for:</span>
					<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
				</label>
				<input type="submit" class="search-submit" value="Search" />
			</form></aside>
		<aside id="recent-posts-3" class="widget widget_recent_entries">
		<h1 class="widget-title">Recent Posts</h1>
		<ul>
											<li>
					<a href="https://martinsvillemedia.com/local/local-news/">Local News</a>
									</li>
											<li>
					<a href="https://martinsvillemedia.com/local/sports/">Sports</a>
									</li>
											<li>
					<a href="https://martinsvillemedia.com/local/obituaries/" aria-current="page">Obituaries</a>
									</li>
											<li>
					<a href="https://martinsvillemedia.com/local/calendar/">Community Calendar</a>
									</li>
											<li>
					<a href="https://martinsvillemedia.com/national/tornadoes-possible-on-east-coast-thursday-as-excessive-heat-continues-in-west/">Tornadoes possible on East Coast Thursday as excessive heat continues in West</a>
									</li>
					</ul>

		</aside>
<aside id="wpp-3" class="widget popular-posts">
<h1 class="widget-title">Trending</h1><!-- cached -->
<!-- WordPress Popular Posts -->

<ul class="wpp-list wpp-list-with-thumbnails">
<li>
<a href="https://martinsvillemedia.com/state/governor-northam-announces-launch-of-new-african-american-history-course/" title="Governor Northam Announces Launch of New African American History Course" target="_self"><img src="https://martinsvillemedia.com/wp-content/uploads/wordpress-popular-posts/12966-featured-75x75.jpg" width="75" height="75" alt="" class="wpp-thumbnail wpp_featured wpp_cached_thumb" loading="lazy" /></a>
<a href="https://martinsvillemedia.com/state/governor-northam-announces-launch-of-new-african-american-history-course/" title="Governor Northam Announces Launch of New African American History Course" class="wpp-post-title" target="_self">Governor Northam Announce...</a>
 <span class="wpp-meta post-stats"><span class="wpp-views">46 views</span></span>
</li>
<li>
<a href="https://martinsvillemedia.com/national/getting-covid-19-and-the-flu-at-the-same-time-what-are-the-risks/" title="Getting COVID-19 and the flu at the same time: What are the risks?" target="_self"><img src="https://martinsvillemedia.com/wp-content/uploads/wordpress-popular-posts/12971-featured-75x75.jpg" width="75" height="75" alt="ozgurdonmaz/iStock" class="wpp-thumbnail wpp_featured wpp_cached_thumb" loading="lazy" /></a>
<a href="https://martinsvillemedia.com/national/getting-covid-19-and-the-flu-at-the-same-time-what-are-the-risks/" title="Getting COVID-19 and the flu at the same time: What are the risks?" class="wpp-post-title" target="_self">Getting COVID-19 and the...</a>
 <span class="wpp-meta post-stats"><span class="wpp-views">27 views</span></span>
</li>
<li>
<a href="https://martinsvillemedia.com/local/kings-grant-names-new-executive-director/" title="King’s Grant Names New Executive Director" target="_self"><img src="https://martinsvillemedia.com/wp-content/uploads/wordpress-popular-posts/12527-featured-75x75.png" width="75" height="75" alt="James Souter, IV" class="wpp-thumbnail wpp_featured wpp_cached_thumb" loading="lazy" /></a>
<a href="https://martinsvillemedia.com/local/kings-grant-names-new-executive-director/" title="King’s Grant Names New Executive Director" class="wpp-post-title" target="_self">King’s Grant Names New Ex...</a>
 <span class="wpp-meta post-stats"><span class="wpp-views">26 views</span></span>
</li>
<li>
<a href="https://martinsvillemedia.com/local/martinsville-man-dies-in-early-morning-crash/" title="Martinsville man dies in early morning crash" target="_self"><img src="https://martinsvillemedia.com/wp-content/uploads/wordpress-popular-posts/12911-featured-75x75.jpg" width="75" height="75" alt="police" class="wpp-thumbnail wpp_featured wpp_cached_thumb" loading="lazy" /></a>
<a href="https://martinsvillemedia.com/local/martinsville-man-dies-in-early-morning-crash/" title="Martinsville man dies in early morning crash" class="wpp-post-title" target="_self">Martinsville man dies in...</a>
 <span class="wpp-meta post-stats"><span class="wpp-views">23 views</span></span>
</li>
<li>
<a href="https://martinsvillemedia.com/uncategorized/desperate-search-continues-for-two-missing-children-swept-away-by-floodwater/" title="Desperate search continues for two missing children swept away by floodwater" target="_self"><img src="https://martinsvillemedia.com/wp-content/uploads/wordpress-popular-posts/12985-featured-75x75.jpg" width="75" height="75" alt="WTVD-TV" class="wpp-thumbnail wpp_featured wpp_cached_thumb" loading="lazy" /></a>
<a href="https://martinsvillemedia.com/uncategorized/desperate-search-continues-for-two-missing-children-swept-away-by-floodwater/" title="Desperate search continues for two missing children swept away by floodwater" class="wpp-post-title" target="_self">Desperate search continue...</a>
 <span class="wpp-meta post-stats"><span class="wpp-views">18 views</span></span>
</li>
<li>
<a href="https://martinsvillemedia.com/local/one-arrest-made-two-at-large-in-bassett-homicide/" title="One arrest made, two at-large in Bassett homicide" target="_self"><img src="https://martinsvillemedia.com/wp-content/uploads/wordpress-popular-posts/12530-featured-75x75.jpg" width="75" height="75" alt="Ashleigh Nicole McCallister" class="wpp-thumbnail wpp_featured wpp_cached_thumb" loading="lazy" /></a>
<a href="https://martinsvillemedia.com/local/one-arrest-made-two-at-large-in-bassett-homicide/" title="One arrest made, two at-large in Bassett homicide" class="wpp-post-title" target="_self">One arrest made, two at-l...</a>
 <span class="wpp-meta post-stats"><span class="wpp-views">15 views</span></span>
</li>
<li>
<a href="https://martinsvillemedia.com/local/local-coronavirus-update/" target="_self"><img src="https://martinsvillemedia.com/wp-content/uploads/wordpress-popular-posts/12475-featured-75x75.jpg" width="75" height="75" alt="coronavirus" class="wpp-thumbnail wpp_featured wpp_cached_thumb" loading="lazy" /></a>
<a href="https://martinsvillemedia.com/local/local-coronavirus-update/" class="wpp-post-title" target="_self">Local coronavirus update</a>
 <span class="wpp-meta post-stats"><span class="wpp-views">15 views</span></span>
</li>
<li>
<a href="https://martinsvillemedia.com/local/local-news/" target="_self"><img src="https://martinsvillemedia.com/wp-content/uploads/wordpress-popular-posts/13012-featured-75x75.png" width="75" height="75" alt="" class="wpp-thumbnail wpp_featured wpp_cached_thumb" loading="lazy" /></a>
<a href="https://martinsvillemedia.com/local/local-news/" class="wpp-post-title" target="_self">Local News</a>
 <span class="wpp-meta post-stats"><span class="wpp-views">13 views</span></span>
</li>
<li>
<a href="https://martinsvillemedia.com/politics/trump-encourages-supporters-to-vote-twice-which-is-illegal/" title="Trump encourages supporters to vote twice, which is illegal" target="_self"><img src="https://martinsvillemedia.com/wp-content/uploads/wordpress-popular-posts/12992-featured-75x75.jpg" width="75" height="75" alt="Official White House Photo by Tia Dufour" class="wpp-thumbnail wpp_featured wpp_cached_thumb" loading="lazy" /></a>
<a href="https://martinsvillemedia.com/politics/trump-encourages-supporters-to-vote-twice-which-is-illegal/" title="Trump encourages supporters to vote twice, which is illegal" class="wpp-post-title" target="_self">Trump encourages supporte...</a>
 <span class="wpp-meta post-stats"><span class="wpp-views">11 views</span></span>
</li>
<li>
<a href="https://martinsvillemedia.com/local/sports/" target="_self"><img src="https://martinsvillemedia.com/wp-content/uploads/wordpress-popular-posts/13004-featured-75x75.jpg" width="75" height="75" alt="" class="wpp-thumbnail wpp_featured wpp_cached_thumb" loading="lazy" /></a>
<a href="https://martinsvillemedia.com/local/sports/" class="wpp-post-title" target="_self">Sports</a>
 <span class="wpp-meta post-stats"><span class="wpp-views">10 views</span></span>
</li>
</ul>

</aside>
<aside id="pages-3" class="widget widget_pages"><h1 class="widget-title">All sections</h1>
			<ul>
				<li class="page_item page-item-252"><a href="https://martinsvillemedia.com/about-the-author/">About Us</a></li>
<li class="page_item page-item-11245"><a href="https://martinsvillemedia.com/contact-us/">Contact Us</a></li>
<li class="page_item page-item-354"><a href="https://martinsvillemedia.com/intranet/">Intranet</a></li>
<li class="page_item page-item-3"><a href="https://martinsvillemedia.com/privacy-policy/">Privacy Policy</a></li>
<li class="page_item page-item-332"><a href="https://martinsvillemedia.com/whee/">WHEE</a></li>
<li class="page_item page-item-334"><a href="https://martinsvillemedia.com/wmva/">WMVA</a></li>
<li class="page_item page-item-352"><a href="https://martinsvillemedia.com/wyat/">WYAT</a></li>
			</ul>

			</aside><aside id="categories-2" class="widget widget_categories"><h1 class="widget-title">All categories</h1>
			<ul>
					<li class="cat-item cat-item-2"><a href="https://martinsvillemedia.com/category/breaking-news/">Breaking News</a>
</li>
	<li class="cat-item cat-item-117"><a href="https://martinsvillemedia.com/category/business/">Business</a>
</li>
	<li class="cat-item cat-item-92"><a href="https://martinsvillemedia.com/category/education/">Education</a>
</li>
	<li class="cat-item cat-item-100"><a href="https://martinsvillemedia.com/category/entertainment/">Entertainment</a>
</li>
	<li class="cat-item cat-item-118"><a href="https://martinsvillemedia.com/category/health/">Health</a>
</li>
	<li class="cat-item cat-item-9"><a href="https://martinsvillemedia.com/category/lifestyle/">Lifestyle</a>
</li>
	<li class="cat-item cat-item-90"><a href="https://martinsvillemedia.com/category/local/">Local</a>
</li>
	<li class="cat-item cat-item-119"><a href="https://martinsvillemedia.com/category/national/">National</a>
</li>
	<li class="cat-item cat-item-4"><a href="https://martinsvillemedia.com/category/obituaries/">Obituaries</a>
</li>
	<li class="cat-item cat-item-5"><a href="https://martinsvillemedia.com/category/opinion/">Opinion</a>
</li>
	<li class="cat-item cat-item-120"><a href="https://martinsvillemedia.com/category/politics/">Politics</a>
</li>
	<li class="cat-item cat-item-14"><a href="https://martinsvillemedia.com/category/regional/">Regional</a>
</li>
	<li class="cat-item cat-item-11"><a href="https://martinsvillemedia.com/category/sports/">Sports</a>
</li>
	<li class="cat-item cat-item-15"><a href="https://martinsvillemedia.com/category/state/">State</a>
</li>
	<li class="cat-item cat-item-1"><a href="https://martinsvillemedia.com/category/uncategorized/">Uncategorized</a>
</li>
	<li class="cat-item cat-item-121"><a href="https://martinsvillemedia.com/category/world/">World</a>
</li>
			</ul>

			</aside></div><!-- #secondary -->
</div><!-- .container -->

</div><!-- #content -->

<footer id="colophon" class="site-footer" role="contentinfo">
	<div class="container">
		<div class="grid">
			<div class="grid__item  site-info">
				<a href="https://martinsvillemedia.com/">© 2020 Martinsville Media LLC</a>
				<span class="sep"> | </span>
				Public File : <a href="https://publicfiles.fcc.gov/am-profile/whee"The Pixelgrade Website" rel="nofollow">WHEE</a>.				<span class="sep"> | </span>
				Public File : <a href="https://publicfiles.fcc.gov/am-profile/wmva"The Pixelgrade Website" rel="nofollow">WMVA</a>.			</div><!-- .site-info -->

			<div class="grid__item  footer-navigation">
				<nav><h5 class="screen-reader-text">Footer navigation</h5><ul id="menu-top-dropdown-menu" class="nav  nav--footer"><li id="menu-item-11251" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-11251"><a href="https://martinsvillemedia.com/contact-us/">Contact Us</a></li>
<li id="menu-item-11250" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-11250"><a href="https://martinsvillemedia.com/privacy-policy/">Privacy Policy</a></li>
<li id="menu-item-294" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-294"><a href="https://ln.sync.com/dl/f23eb01c0/dj3uppwu-hk8tbffc-fx5k8zht-yhnd2ctu">Uploader</a></li>
</ul></nav>			</div>
		</div>
	</div><!-- .site-footer .container -->
</footer><!-- #colophon -->
</div><!-- #page -->

			<script>
				window.addEventListener('load', function() {
					// Trigger the 'wf-active' event, just like Web Font Loader would do.
					window.dispatchEvent(new Event('wf-active'));
					// Add the 'wf-active' class on the html element, just like Web Font Loader would do.
					document.getElementsByTagName('html')[0].classList.add('wf-active');
				});
			</script>
			<script type='text/javascript' src='https://martinsvillemedia.com/wp-includes/js/imagesloaded.min.js?ver=4.1.4' id='imagesloaded-js'></script>
<script type='text/javascript' src='https://martinsvillemedia.com/wp-includes/js/masonry.min.js?ver=4.2.2' id='masonry-js'></script>
<script type='text/javascript' src='https://martinsvillemedia.com/wp-includes/js/hoverIntent.min.js?ver=1.8.1' id='hoverIntent-js'></script>
<script type='text/javascript' src='https://martinsvillemedia.com/wp-content/themes/hive-lite/assets/js/velocity.js?ver=1.1.3' id='velocity-js'></script>
<script type='text/javascript' src='https://martinsvillemedia.com/wp-content/themes/hive-lite/assets/js/main.js?ver=1.3.3' id='hive-scripts-js'></script>
<script type='text/javascript' src='https://martinsvillemedia.com/wp-includes/js/wp-embed.min.js?ver=5.5.1' id='wp-embed-js'></script>
	<script>
		/(trident|msie)/i.test(navigator.userAgent)&&document.getElementById&&window.addEventListener&&window.addEventListener("hashchange",function(){var t,e=location.hash.substring(1);/^[A-z0-9_-]+$/.test(e)&&(t=document.getElementById(e))&&(/^(?:a|select|input|button|textarea)$/i.test(t.tagName)||(t.tabIndex=-1),t.focus())},!1);
	</script>
	
</body>
</html>
